I made a deposit to my Emerald Wallet Address - Never Showed Up

I made a deposit from my ETC wallet on Bittrex to my Emerald Wallet address on 12/26. I saw no evidence of it in my Emerald Wallet, even after several hours. I ultimately removed and reinstalled Emerald Wallet and tried to import the wallet key I’d previously been given by copying and the entering the QR code serial no. It still shows no balance.

Contact Bittrex. It’s most likely an issue on their end.

Also you can put your public address into http://gastracker.io and see if the ETC arrived. If not then it’s definitely on Bittrex’s end.

1 Like

I did just plug my emerald wallet address into gastracker and it states that .99 etc was deposited into my emerald wallet address on December 26th at block 5090452, 0x27b04cdc332392cdebbb70cf7df3be6f282d1db6

Yet that amount was never credited to my Emerald wallet Balance.

Do you use a local node or remote one? if remote, is it epool.io or gastracker?

I guess a local one since I didn’t specify.

If it’s a local node you need to wait for blockchain sync to see final balance. You should see a green progress bar on top right side, it could take few days, in some cases even more than a week to synchronise blockchain.

You can always switch to epool/gastracker remote nodes, and return back to local node, etc. See selector on top right corner


Just to clarify, if you use the epool/gastracker remote nodes you won’t need to wait for the wallet to sync.

I just tried. I’m clueless. Here is the transaction ID if it helps.


It’s definitely there. As long as you control that address you should be able to use it.

Quick question, can you make sure your system’s clock is sync’d? Google “sync system time windows” or whatever your operating system is. Sometimes syncing doesn’t work if your clock is off.

Although if you use epool/MEW nodes it should just work regardless.

Did you end up getting your money?