Need a working testnet


#1

Hi, I tried to launch geth with morden testnet but it cannot sync with net cause there are no seeds.
geth --fast --testnet --verbosity 5

etc-geth_1   | I0402 11:34:41.184868 eth/backend.go:155] Protocol Versions: [63 62], Network Id: 2, Chain Id: 62
etc-geth_1   | I0402 11:34:41.185502 core/config.go:623] Genesis block 0x0cd786a2425d16f152c658316c423e6ce1181e15c3295826d7c9904cba9ce303 already exists in chain -- writing canonical number
etc-geth_1   | I0402 11:34:41.185598 eth/backend.go:183] Blockchain DB Version: 3
etc-geth_1   | I0402 11:34:41.185675 eth/backend.go:234] Successfully established morden testnet genesis block: 0x0cd786a2425d16f152c658316c423e6ce1181e15c3295826d7c9904cba9ce303
etc-geth_1   | I0402 11:34:41.185962 core/blockchain.go:687] Last header: #0 [0cd786a2?] TD=131072
etc-geth_1   | I0402 11:34:41.185979 core/blockchain.go:688] Last block: #0 [0cd786a2?] TD=131072
etc-geth_1   | I0402 11:34:41.185988 core/blockchain.go:689] Fast block: #0 [0cd786a2?] TD=131072
etc-geth_1   | I0402 11:34:43.288473 node/node.go:295] IPC endpoint opened: /root/.ethereum-classic/morden/geth.ipc
etc-geth_1   | I0402 11:34:43.790709 p2p/discover/table.go:388] no seed nodes found
etc-geth_1   | I0402 11:34:47.795376 p2p/discover/table.go:388] no seed nodes found
etc-geth_1   | I0402 11:34:51.799845 p2p/discover/table.go:388] no seed nodes found
etc-geth_1   | I0402 11:34:55.799715 p2p/discover/table.go:388] no seed nodes found
etc-geth_1   | I0402 11:34:59.796037 p2p/discover/table.go:388] no seed nodes found

Block explorers http://testnet.epool.io and https://mordenexplorer.ethertrack.io/home are also down.
Is morden dead?

I found than you recently launched Kotti testnet. There is live explorer here - https://kottiexplorer.ethernode.io/home

I managed to run kotti via multi-geth client but it cannot sync with net:
geth --syncmode "light" --kotti --verbosity 3

multi-geth_1  | INFO [04-02|12:51:55.663|node/node.go:189]        Starting peer-to-peer node               instance=Geth/v1.8.23-stable/linux-amd64/go1.11.6
multi-geth_1  | INFO [04-02|12:51:55.663|ethdb/database.go:74]    Allocated cache and file handles         database=/root/.ethereum/kotti/geth/lightchaindata cache=512.00MiB handles=524288
multi-geth_1  | INFO [04-02|12:51:55.705|trie/database.go:720]    Persisted trie from memory database      nodes=357 size=50.93KiB time=1.151951ms gcnodes=0 gcsize=0.00B gctime=0s livenodes=1 livesize=0.00B
multi-geth_1  | INFO [04-02|12:51:55.706|les/backend.go:89]       Initialised chain configuration          config="{ChainID: 6 Homestead: 0 DAO:  DAOSupport: false EIP150: 0 EIP155: 0 EIP158:  Byzantium:  Disposal: 0 Social:  Ethersocial:  ECIP1017: 5000000 EIP160: 0 ECIP1010PauseBlock: 0 ECIP1010Length: 2000000 Constantinople:  ConstantinopleFix:  Engine: clique}"
multi-geth_1  | INFO [04-02|12:51:55.708|light/lightchain.go:159] Loaded most recent local header          number=0 hash=14c228?c743c4 td=1 age=2mo4w1d
multi-geth_1  | INFO [04-02|12:51:55.722|p2p/discv5/udp.go:243]   UDP listener up                          net=enode://f8ea86c8dee37e0b5acee9a8c9c5504114a405f19179798f344f448feb610810c[email protected][::]:30303
multi-geth_1  | WARN [04-02|12:51:55.723|les/backend.go:261]      Light client mode is an experimental feature 
multi-geth_1  | INFO [04-02|12:51:55.724|p2p/enode/localnode.go:240] New local node record                    seq=3 id=8aea61d09e105f4b ip=127.0.0.1 udp=30303 tcp=30303
multi-geth_1  | INFO [04-02|12:51:55.724|p2p/server.go:605]          Started P2P networking                   self=enode://f8ea86c8dee37e0b5acee9a8c9c5504114a405f19179798f344f448feb610810c[email protected]127.0.0.1:30303
multi-geth_1  | INFO [04-02|12:51:55.724|node/node.go:338]           IPC endpoint opened                      url=/root/.ethereum/kotti/geth.ipc
multi-geth_1  | INFO [04-02|12:51:55.725|node/node.go:366]           HTTP endpoint opened                     url=http://0.0.0.0:8545            cors= vhosts=localhost

From js console I got:
admin.peers []

I also tried to connect to https://kotti.ethereumclassic.network from MEW, MYCRYPTO, METAMASK Web wallets as a custom net. But have no success. Although I managed to add ETC mainnet as custom net in Metamask from rpc endpoint https://ethereumclassic.network

  1. How to correctly connect to any working testnet/kotti ?
  2. How to deposit account in test ETC?

UPDATE:

  1. Managed to sync with kotti in multi-geth fastmode.

#2

Yep I was going to say, LIGHT mode is super experimental more so when using it with Kotti. But Kotti is super light weight so fast mode is perfect even full node is not very cumbersome.


#3

Hi, Yep. Fast mode is working great. What about funding a kotti account by some test coins? I have’t found any faucet for it.